HTTPで送信できないことがある

投稿者:onichan 投稿日:2023/04/14(Fri) 20:21:27 No.2277

いつもお世話になっております。

プロデル1.9.1182で、`HTTPで【アドレス】へ【パラメータ:辞書】を〈【ヘッダ:辞書】にて〉〈【文字コード】として〉送信する:文字列`が動作しなくなっているようです。

ーープログラム例
パラメータ(「search」)は「プロデル」
https://rdr.utopiat.net/cgi/post.php」へパラメータをHTTPで送信して内容とする
内容を報告する

ーープログラム終わり

ーーエラーメッセージ
動詞『送信して』に適した手順が見つかりません。
複文ではない呼出し文で補語は省略できません。

手順の候補:
[HTTP]で【アドレス:文字列】へ〈【パラメータ】を〉〈【ヘッダ】にて〉〈【文字コード】として〉送信
[HTTP]で【アドレス:文字列】へ【バイナリ:バイナリデータ】を〈【ヘッダ】にて〉送信

[エラー番号129] [はじめ:2行目]
プロデル 1.9.1182 (64)

ーーエラーメッセージ終わり

状況:外部のAPIを使うアプリでエラーになり発覚しました。
OS:Windows 10 22H2(19045.2846)
よろしくお願いいたします。

修正しました。プロデル1.9.1183

投稿者:ゆうと 投稿日:2023/04/21(Fri) 22:45:31 No.2285

onichanさん
  お世話になっております。

再現できました。
プロデル1.9.1182でJSON関連での辞書の件を修正したことが原因だったようです。

関連する現象が起こる可能性がありますが、とりあえずご確認ください。
ご指摘ありがとうございます。

修正確認しました。

投稿者:onichan 投稿日:2023/04/22(Sat) 13:54:05 No.2287

お世話になっております。

現象が1.9.1183で修正されていることを確認いたしました。
ご対応いただきありがとうございます。
今後ともよろしくお願いいたします。

1.9.1216で再発

投稿者:onichan 投稿日:2024/02/02(Fri) 18:52:26 No.2322

いつもお世話になっております。

HTTPの送信手順が動作しない現象について、ほぼ同様の現象が1.9.1216から発生しているようです。

ーープログラム例
https://rdr.utopiat.net/cgi/post.php」へ{search=「プロデル」}をHTTPで送信

ーープログラム終わり

ーーエラーメッセージ
「送信」という手順が複数あり、どの手順を実行するか決められません。
引数の助詞や型が合うように指定してください。

手順の候補:
[HTTP]で【アドレス:文字列】へ〈【パラメータ】を〉〈【ヘッダ】にて〉〈【文字コード】として〉送信
[HTTP]で【アドレス:文字列】へ【バイナリ:バイナリデータ】を〈【ヘッダ】にて〉送信

[エラー番号117] [はじめ:1行目]
プロデル 1.9.1217 (64)

ーーエラーメッセージ終わり

OS:Windows 10 22H2(19045.3930)
よろしくお願いいたします。

1.9.1218で修正済みです

投稿者:ゆうと <yutopia あっとまーくutopiat.net> 投稿日:2024/02/03(Sat) 23:25:05 No.2323

お世話になっております。

> HTTPの送信手順が動作しない現象について、ほぼ同様の現象が1.9.1216から発生しているようです。

丁度、リリーステストの際にエラーを見落としていることに気が付きました。
1.9.1218で修正済みです。

お試しください。
ご指摘ありがとうございます。

確認しました

投稿者:onichan 投稿日:2024/02/04(Sun) 08:02:15 No.2324

お世話になっております。

現象が1.9.1218で修正されていることを確認いたしました。
ご返信いただきありがとうございます。
今後ともよろしくお願いいたします。

▲ページの先頭へ

- WebForum -